Jump to content

All Activity

This stream auto-updates     

  1. Today
  2. oldskooler

    Devon and Melons

    Yarp. One night in Devon...one night in Devon An absolute horror of a machine this is. Although there are clones (Mega Money), this was the face of humility for most players. I could digress, but I think I've given an in-depth review before. Oldskooler
  3. mrx

    Devon and Melons

    soft or perky
  4. warlord

    Mpu3 frustration!

    Pretty sure you will sort it.As Chris said it's more than likely a bad connection.its just finding it.Also get a torch and look straight into the female side of the plug,the metal contacts in those when old can squash down and no longer brush the pins they push onto.I had this with warlord,it would work,then it went wappy displaying odd segments on displays and either losing or not playing with credit,this was down to the female connector on the mpu board where it slides in and out of machine and connects to a PCB in rear of unit.since replacing that socket,about a 12 way I think it's been fine.
  5. niftynudger

    Devon and Melons

    I’ve played with a few pairs of melons in devon.
  6. launton

    Today in isolation

    There might be some reel scans of this machine from when I owned it on the mecca in my downloads. Those decals are much better
  7. Dazza

    Devon and Melons

    Devon and Melons lol, I thought I’d played them all
  8. Dazza

    Today in isolation

    Just put some picks in MFME development. The machine is in my garage and has no natural light so the glass pics aren’t great let me know if you want you think if not I’ll drag it out later get some better pics
  9. MikeB

    Mpu3 frustration!

    Cheers chaps, I have got plenty to be trying now. As always some solutions there that will hopefully get her up and running 👍
  10. superbank

    Today in isolation

    I think create a separate thread and post them there. I'm sure one of our world class layout creators will be glad to take the project on. Much appreciated by the way, always good to get old classics updated.
  11. Line Up Chris

    Mpu3 frustration!

    It's not just the red and green leads. I'd unplug all the small green leads on the reel driver board too. Spray contact cleaner into the end of each lead. And at each end for the red and Green big leads. the opto lights should light up when spinning. If one stays on,that where the problem is! This fault is usually only a bad contact. The reel opto lights should remain off when stationary. If you move a reel by hand then it will flicker on. That will tell you that one works ok. I have to do this with all my mpu3s every few months. They run pretty sweet now. Maybe a run over those pins with a fibre pencil may also rectify this. Hope you sort it Mike.
  12. Yesterday
  13. warlord

    Mpu3 frustration!

    Now that's weird,getting fault with reels not connected.so that tells me it's not a reel fault.can you try this board in another machine or try another mpu4 in the problem machine.its all a case of trial and error and narrowing it down to find the fault
  14. Phil1974

    Mpu3 frustration!

    Have you tryed another deck from a know working Mpu3 ? Just to see if it’s a deck the problem or leads / board etc ..
  15. warlord

    Mpu3 frustration!

    Hope you sort it Mike,maybe summat simple it's just finding it.although you have had some great advice
  16. MikeB

    Mpu3 frustration!

    Yes I have checked all the options Lights Andrew, and they are all lit. I Assume I am not missing something here! The board was working fine when I took the reels out. 🤔
  17. alex74.

    PCP Mirracles

    Superb thanks very much for this lovely machine. One I never played in the wild so am really looking forward to it. PCP got so much out of their rebuilds on original techs creating games that were often better than the original. Thanks again for the layout.
  18. Andrew96_

    Mpu3 frustration!

    It is not unknown for previously ok sensors to go faulty, the opto receivers fail like there is no tomorrow these days when pressed into service!! It could be if the motors are now noisy with this board that a motor drive transistors has gone so the mpu is expecting to see a opto pulse at a set time and it doesn’t!! Or perhaps the mpu you have put in has a opto fault check the lamps on each reel lights and shines through the hole in each reel, and as rich says the plugs!!!!!
  19. vectra666

    Today in isolation

    the ones above were clear enough, if they had the whole machine glasses in them it would be dx'ed by now lol i'd love to see ploggy take this on as its his thing, where is ploggy these days is he still active?? Actually anyone can take it on, alteredemu aka fuzion makes these outstanding his 777heaven dx for instance is 100/10
  20. Dazza

    Today in isolation

    Ok mate I’ll do some tomorrow, have you got an email address to send them to or just put them on here?
  21. MikeB

    Mpu3 frustration!

    Yep that makes sense Rich, I will try that! I have reseated the leads probably 25 times so far 😂😂 bloody things! But I will give the ram clear a crack! Thanks for the advice 👍
  22. riche100

    Mpu3 frustration!

    oh and check that the green and red plugs to the reel board and mpu board are seated fully, as sometimes they catch on the case
  23. riche100

    Mpu3 frustration!

    clear the ram of the machine, as it might be remembering the fault if it doesnt help sorry , just a idea keep at it
  24. MikeB

    Mpu3 frustration!

    Evening all, I have been sorting out my Royal Exchange clubber I’ve the first week of this lockdown! Been doing a few bits to it, first of all the mpu was replaced with a working board, super it fired straight into life, playing it for a few days, with no issues, except reel 1 and 2 were very noisy. I thought I would quickly change the motors from my spares, all went back together and here is where the issues started. I keep getting a reel A fault, I’ve swapped changed sensors etc. Moved 1 to 2 etc, cleaned all of the plugs, all of the usual. And I continue to keep getting the same fault. If I leave the reels unplugged I still get the same fault. Has anyone got any ideas of what I can do next please. As it is driving me nuts! Cheers for any help. 👍
  25. superbank

    Today in isolation

    Camera phones are perfect to be honest Dazza - the resolution on them is excellent. Take as many as you can please mate. If you need to use a flash then please take them at a slight angle so it doesn't affect the picture too much. If you can get away without a flash then even better! Reel symbols always appreciated as well. Thanks a lot for this. It's such a great machine, would be fantastic to see this get an update.
  26. Dazza

    Today in isolation

    Hi mate, I only have the camera on my I phone would they be good enough? I have no problem doing whatever pics you want Reel bands ect let me know. Darren
  1. Load more activity
×