Jump to content

Maygay mario kart 64 fruit machine


Darklink87
 Share

Recommended Posts

Good afternoon new to the site could someone help me I have brought a mario kart 64 maygay fruit machine it wasn't working but I removed the mpu board and cleaned it up due to the battery its now powers up working only issue is the alpha not working. I have used a multimeter on the lamp board and have power also tested the ribbon cable to the alpha this also has power any help would be great thank you.

Link to comment
Share on other sites

Could be the lamp board (most probably the socketed pic chip if it's the mk1) or the alpha display itself. I'd try a whole new lampboard first. You mustn't unplug anything in the lamp board, alpha display, or the grey serial link with the machine switched on. That can blow any of the above or take out the serial driving on the main board (nightmare scenario).

  • Like 1
Link to comment
Share on other sites

Lampboard first £20-£25 Try and get one someone can guarantee is working. Don't use any thing with burn marks on it. Give it a light clean don't want it covered in grime or dust because it will get hot.

Alpha display second.

Main board if the game plays, has sounds and no errors the serial output should be working ok. If it does nothing or random lamps on then you have problems.

Link to comment
Share on other sites

It's not super rare my mate has one... You have all those tried and tested cloned Maygay games spanning across m1 and Epoch (Great escape, Italian job, Simpsons blue, Homers meltdown, Mario kart, probably a few more) all pretty much the same game. Mario is one of the least numbers out of all of those because the others are all classics. 

Some people like them... if you have a Sonic and a Donkey Kong I'm sure you'll want one 🙂

Link to comment
Share on other sites

 Share

×
×
  • Create New...