Jump to content

Tales from Midibob's workshop. MPU3


midibob
 Share

Recommended Posts

Hi chaps,

 

I've been working on four MPU3 boards which I'm really getting the hang of now.

 

This one was quite interesting as it was a rev 1 board which I've not seen before. The RAM you can see is a 6116 and I didn't think these were fitted until later rev boards? Also it has two extra wires going back to the ROM cart socket.

 

post-6626-0-95620500-1439370162_thumb.jpg

 

Original fault was no boot. (there's a surprise)

All the usual suspects RAM voltage transistors T60/61 and the RST T59. C37 was broken (CPU xtal) and replaced.

 

Still no boot though.

 

Memory was swapped but no difference. Looking a bit deeper IC24 was bad as there was no pulse on the CS for the RAM. Should have checked that first, Doh!

 

Still no boot. Hmm.

 

Noticed one of the reels wasn't juddering correctly on boot and would move one step if you touched it gently. This was due to T48 reel driver going open cct.

 

Still no boot.

 

Brainwave moment, the board isn't on the test rig proper as yet, I don't put them on till I've got them initialising properly. Long story but bear with me for now.

So the old grey matter is thinking I wonder if there is an alarm going off as there is no speaker connected. Checking on T11 there's a pulse (ie an alarm), great, that means it is booting but something is halting the system. A stuck input perhaps?

Most likely culprit is IC6 so in goes a new one and bingo all reels spin with sensors alight.

 

Next board to follow later.......

Link to comment
Share on other sites

Here's the next one.

 

post-6626-0-36646600-1439378807_thumb.jpg

 

Again a non booter.

A bit of corrosion around the RAM voltage cct area so most of the small resistors have been swapped out. Quite a few fell apart on removal!

The original RAM sockets were badly contaminated too so they had to come out. The original RAM was also knackered. To enable the use of Andrew's RAM boards, turned sockets couldn't be used so I had to get some more of the ordinary ones as I don't keep them normally.

 

Blown T60/61 as per usual as well as T59.

 

Reset is now OK but there's no reel twitch? Also the reel sensors are alight all the time! Back to T55 which is s/cct.

 

Still no boot though!!

 

As it was getting late and I had had problems with the 6840 before preventing boot up I thought I'd quickly remove it just to see. I should really think about these things before I rush in as this time it was totally innocent.

 

Anyway, fresh head in the morning and put my logic head on. Checked T11 for any alarm pulse and yep there it was. Now was it the same as last time? Just thought I'd check the chip select lines first to the PIA's and what do you know they were missing to IC5 & 6. As IC5 drives the reels that would explain a lot. So back to IC9, whip it out and put in a new one. Bingo again.

 

Another riveting instalment to follow.....

Link to comment
Share on other sites

...and here it is!

 

This one was a bit easier but still keeps you guessing.

Nice and clean with no corrosion which was nice.

post-6626-0-59508800-1439452390_thumb.jpg

 

The board was resetting OK but not initialising. Most the usual suspects were OK this time except for T60 so the RAM voltage was too low.

C20 was missing (liquorice allsort capacitor!) although the legs were still there.

 

Whilst it was trying to initialise I noticed there was no drive to reel A. Next thing I noticed was my forearm touched the reel driver transistors and I let out a loud yelp!! T40,41,& 42 were really hot.

 

Now this is where it's easy to go off at a tangent. I had noticed that IC12 had been written on the front cover so someone had been here before! Steaming in I swapped out IC12 but of course no difference.

Next step was to remove the transistors and test them. All OK?? What's going on here??

 

The replacements weren't the Ferranti E-line package albeit the right transistors though. Looking up the footprints showed they were put in back to front!! It's a pity I didn't take a picture first otherwise I could of had a 'guess the fault' session.

 

So that's another one ready for full testing in my machine.

Link to comment
Share on other sites

... and the final board.

 

This one had diode packs on it as you can see.

 

post-6626-0-49003700-1439563885_thumb.jpg

 

This booted and initialised fine but on the test rig one of the buttons didn't work. This was due to one of the diodes in the middle diode pack going open cct. Not having one of these horrible devices I swapped the whole pack out as it will be easier to fault on in the future.

 

Going back to board number two in the saga. When it was put on the test rig all seemed to work except the slightest vibration caused it to lock up. After a bit of head scratching I located it to the RAM cart. Moving it sideways slightly caused the lock up. On inspection I noticed there was slight corrosion on the last pin (Gnd) and a bit of cleaning and a bit more tension it was as solid as a rock.

 

During testing I would get intermittent reel alarms and I also noticed that sometimes the reels would twitch. Hmm, the regulator caps look original. Chucked in a new set and it's Bingo again. :)

Checking the ESR on the old caps showed the 40v and one of the 25v ones to be about 14Ohms, they should measure somewhere around .05 Ohms.

 

Just got to do the final tests of the boards in my Cabaret machine and hopefully I can wrap these up.

 

The next step is ACE System one boards, so I'll be recounting some more tales from the workshop in a few days.

 

Happy days (as Rich would say).

Edited by midibob
  • Like 1
Link to comment
Share on other sites

Good work Bob!!

 

I never seem to find time to write up about stuff I've been fixing as the pile of stuff to fix keeps getting bigger :)

 

Do you have some parts that you just swap as you know they will probabley fail soon after they go back... for example I tend to do the same mods then swap the battery transistors on MPS2 if the off current is higher than 0.002mA...

Link to comment
Share on other sites

I suppose that's not a bad rule of thumb but for now I'm just changing bits that actually show a fault. Mind you if you've got to take the transistor (or any part for that matter) out for testing it's probably just as easy to put a new one in anyway.

I do like to know if a part is actually faulty otherwise you never get to understand the circuit properly.

 

Some things are best left alone though. Unless there's a very good reason I wouldn't remove Triacs on these boards as usually the solder has been contaminated and you then need a lot of heat to melt the joint this can then lead to track lifting. I've seen an awful lot of this and it's a nightmare to renew, although not impossible (see my Scorpion one thread).

Link to comment
Share on other sites

One last sting in the tail (or should that be tale?).

 

On the Cabaret machine it has 4 reels where as the test rig only has 3. One of the boards showed a twitchy reel D. It played OK though but you could hear it buzz too when idle. After checking the reel transistors and swapping out the associated 7404 it was still there? IC5 (6821) had already been socketed so maybe someone had been here already. Slipped in another and bingo again.

  • Like 1
Link to comment
Share on other sites

  • 4 weeks later...

This one had the memory sockets and ic9 & 24 missing. Some of the transistors had been changed as well as D45. None of the leads had been cropped which is a bit iffy.

I suspect a too hot iron was used for component removal as some pads were missing and others loose.

 

post-6626-0-15117500-1442076194_thumb.jpg post-6626-0-14732700-1442076191_thumb.jpg post-6626-0-07201000-1442076192_thumb.jpg

 

So it's in with a few rivets and also adding a small piece of track cut from the good old gardeners copper labels.

 

post-6626-0-72788600-1442076192_thumb.jpg post-6626-0-42565800-1442076193_thumb.jpg

 

Still a work in progress at present but it's coming along nicely.

 

You may notice that some of the track has been cut around IC24 and I suspect this is to mod the board to take a 74ls12 instead of the 74ls03.

I don't know if this was a recommended mod or whether it's a bodge? Luckily it's easy to revert but I'll see what the feedback is from you guys.

Link to comment
Share on other sites

  • 3 weeks later...

Having some real headaches with this tech at the moment.

 

Managed to get one working today but it's taken a good few days on and off to get to the bottom of it.

 

Started with all the usual culprits in the reset cct and the RAM/battery charge cct. This was followed by corrosion getting in to IC9 and 24 as well as the RAM sockets.

After sorting all this it still wouldn't boot.

 

Checking the 4MHz oscillator the output was quite low. A new crystal bought the level quite a lot and the waveform looked more stable too. It was still a little low though so the CPU was also changed and this brought it up even more. Just goes to show that although the components still function they are running well below par.

 

As you've guessed there was still no boot but at least I was sure the main clock wasn't to blame.

 

All data and address lines were running so were all the CS lines, I hate these faults. This is usually where all the support chips need to be removed and substituted to see which one or ones are stopping the boot process. Looking at all these chips underneath it appeared that they'd all been removed before so someone had probably had a go at this and given up. I know I nearly did!

 

Another thing I wasn't happy with was the 5v regulator as it was putting out about 5.14 volts which is getting rather high so I put a new one in which bought it back to 5v.

 

One thing I hadn't checked was the 100Hz clock derived from the PSU and low and behold it wasn't there (pin 12 IC18).  Checking the input (pin 13) with the scope showed the waveform OK but the output was in the millivolts?

This line only goes to two other devices, one of the 6821's and the 6840. Quickest thing was to swap out IC18 first in case the chip was faulty, which it wasn't!!

Next quickest was to remove the 6840 and bingo, the clock pulse was now normal.

 

The MPU should boot without the 6840 but it still didn't! By now I was losing the will to live.

 

It was looking like the only option was to socket all the rest of the support chips and substitute. On a hunch though, I felt all the tops of the support chips and noticed that IC6 (6821) was almost cold, this is unusual as they normally run warm. Put in  a new one and, hurrah, it works.

 

Some more horrors await so keep watching for the next thrilling instalment.

Oh, and if you see an article on the news about 'South London man jumps in Thames' that'll be me!

  • Like 1
Link to comment
Share on other sites

thanks for the update bob , please dont do anything silly to yourself

 

without pain there is no pleasure :) 

 

you will get there, and learn big lessons on the way .

 

i so enjoy reading about your exploits and thank you for sharing them with us

 

and most of all for having a go on the techs 

 

happy days now and always :) 

Link to comment
Share on other sites

 Share

×
×
  • Create New...