Jump to content
Sign in to follow this  
Tomek515

Reelmagic with Scorpion 1, repair/restoration

Recommended Posts

Hello colleagues. 😀

I recently got a reelmagic machine with a Scorpion 1 motherboard.

19CCA209-52B7-4E4E-BB25-5D97C95CD5F1.jpeg

 

Unfortunately the machine doesn't work. I would like to try to get it working, but I will definitely need your help. I lack information and knowledge. The machine looks complete. There is probably nothing missing inside. After switching on, the cylinders rotate for a few cycles and then nothing happens.

 

It seems to me that I will start by removing the power supply and motherboard and checking these elements because everything is dirty and you can see corrosion.

1653EEB6-B89E-4492-BB02-E5505C551E14.jpeg

81E40446-8EC9-4F53-962B-AA095296B9A6.jpeg

DBD59139-1523-4F67-A661-53AFA6F16B50.jpeg

69DD2CDF-27ED-423B-8129-7CAE9E3A52AB.jpeg

I will describe further progress in this topic. I will need a machine diagram and manual, I saw that there are these materials somewhere on the forum, but I probably don't have access to them

Edited by Tomek515

Share this post


Link to post
Share on other sites

I recommend you take pictures as you take disconnect or take anything apart to help you put it back correctly.  Good luck with your restoration.

  • Like 1

Share this post


Link to post
Share on other sites

Today I took out the motherboard and power supply.

B882EEC4-9687-41F3-8C38-BC08B91DBF3B.jpeg

E07C341F-54DB-45C9-BEB8-4DD358216482.jpeg

In the power supply, 22000uf 25v and 4700uf 63v capacitors are swollen on top. I decided to replace all the electrolytic capacitors in the power supply and on the board. I have to buy them.

A5571991-C12A-44C9-86C5-80AAC2333105.jpeg

1C6939A9-9803-4BA3-B700-040F5731F363.jpeg

Memory battery leaked on the motherboard. I washed off the raid and took out the batteries.

560AD57A-54D3-4DDA-A45F-1E36C709FFC7.jpeg

A9EDBB2C-67FA-44B9-857F-4CCAA8BC7529.jpeg

Next to it there is a transistor screwed to the heat sink.

0B5A70AF-115E-46AC-97B3-18C1185D1F6E.jpeg

There are traces of an old repair on the disc. I must check this.

62652E56-940A-48E6-95B8-16D739B7463F.jpeg

resistor 211 looks very bad. I removed it and measured the value is 2.2R but I do not know if it is the correct value because it is impossible to read the stripes. Maybe someone will help and give a value from the diagram.

90BEE36B-113D-4D52-9A8B-29914DE18213.jpeg

I checked the power supply but the given voltages are a bit strange for me. The power supply gives different values on different pins. 5.2V, 43V, 15.2V, 42.8V

 

I wonder if the film capacitors should also be replaced on the motherboard (I mean those in a white plastic housing), I do not know if they get old as it happens with electrolytic ones)

D811B9C8-377D-4355-9E0E-CC2FD95C2C19.jpeg

Edited by Tomek515

Share this post


Link to post
Share on other sites

R211 is 2.7R

Get a single pole DIL switch for SW1.

There's lots more info on my workshop thread for Scorp1.

Good luck.

  • Like 2

Share this post


Link to post
Share on other sites

(I've only done one scorpion 1... so far 🙂) The big heat sync- it's not a transistor screwed to it, it's the 5v regulator.

The box Capacitors seem ok to, me I took them off and tested them to be sure in the battery area. The small dielectric caps in the audio area were not good on my board. 

I'm finding the wiring loom contacts the most time consuming to sort out... it's best to clean up every pin on the mpu while you have the board out... and read Bobs thread it's invaluable 😎

Edited by MattyL
  • Like 1

Share this post


Link to post
Share on other sites

By mistake, I called the regulator a transistor. Sorry mistake 😁 Today I replaced the capacitors on the motherboard and in the power supply, but unfortunately they were of a different size and I had to make changes. I hope that this is not a problem. I bought a 211 resistor 2.7r 0.5w, not as originally 0.25w, there were no other in the store. I think it will be ok too? I still have to buy SW1 switch. There is a spacer between the regulator and the heat sink that I need to buy. I have a question, should I put thermal paste between the plate and the heat sink?

I think that for now I will mount the motherboard and check if anything turns on. This will give me an egergy for further work. I just don't know if I can run the machine. there are two keys on the front. I don't know what they are for.

I don't have a battery and I wonder if I can run the game properly without it. I wonder what to buy.

E9962B4E-C9B5-4C35-9A97-D2F9FF681F85.jpeg

B67FD91A-B438-4ECC-9684-454FE6BA9FC2.jpeg

56D56A61-3E9F-441E-B73A-6161BAE562BA.jpeg

66B83C10-F1E1-4D78-AD7A-8A14A363B1B6.jpeg

Edited by Tomek515

Share this post


Link to post
Share on other sites

yes you can run the machine with out the battery on it you will get a error 53 then it will boot up 

  • Thanks 1

Share this post


Link to post
Share on other sites

I installed all the elements but without the memory battery. Sound works but nothing shines. The door opening alarm is also triggered. I have no ideas what to do next.

🤔

Share this post


Link to post
Share on other sites
Sign in to follow this  

×