Jump to content
Chris1965

Bellfruit who wants to be a legionnaire

Recommended Posts

Hi again guys is Chris I had my machine working but no lights and switched it on today and some lights have come on and not all some and an error code 31 mux row error/ multiplexer alarm-row check lamp can anyone help please

Share this post


Link to post
Share on other sites

your main board has a fault, most likely through battery degassing causing tracks or components to fail on the board as battery is unlikely to have been changed every 3 years

Share this post


Link to post
Share on other sites
Posted (edited)

Check the mini MUX board inside the machine.  If loose plugs/cracked solder joints

 

but coukd be acid damage on main board causing issues with other parts 

Edited by Generation

Share this post


Link to post
Share on other sites

Keep it switched off if any lamps burn unnaturally bright or can burn the artwork and melt the lamp mask.

Share this post


Link to post
Share on other sites

it sounds like to me you have a faulty transistor on the board that has green legs or track damage through leaking battery

Share this post


Link to post
Share on other sites

Thanks for all your help 😎😎😎 gonna start with taking the scorpion 4 board out and having a nose 👃 lol 😂 got to laugh about it or you’ll cry 🤪

  • Like 1

Share this post


Link to post
Share on other sites

can we see some close up pics of the board

Share this post


Link to post
Share on other sites

That's the breakout board, not the scorp 4. Nothing on there would cause a mux row error apart from 2 pins crammed into the same hole (Yes I have seen this before)

Share this post


Link to post
Share on other sites

New board. The battery has shat all over that one.

Share this post


Link to post
Share on other sites

It's probably repairable if you're good with a soldering iron and have the patience of a saint. 

Share this post


Link to post
Share on other sites
On 8/1/2020 at 12:03 PM, Andrew96_ said:

your main board has a fault, most likely through battery degassing causing tracks or components to fail on the board as battery is unlikely to have been changed every 3 years

I said that on Saturday 🤣

Share this post


Link to post
Share on other sites

Thanks for all the help guys will show ya all it working soon I hope 🤞👍🏻👍🏻

Share this post


Link to post
Share on other sites

×