Jump to content
midibob

JPM MPS1 RIFA's

Recommended Posts

Hi chaps,

Just got a few of these in to check out and the usual issue of the RIFA caps cracking up or in this case worse.

980268059_P1040144(Custom).jpeg.f0c4e8ab8dca3979607a1af3f83fc036.jpeg

Most folks seem to remove all 4 and then replace the function by fitting a filtered mains socket. What's the consenus on leaving out C4 as it's the other side of the choke from the mains supply?

1350268234_P1040143(Custom).jpeg.4269d2a62ba38a301a3bd7028db0f925.jpeg

701090089_RIFAcaps.thumb.png.6fe8a8ddcebdc7bb518282186cd2b538.png

My thoughts would be it should be fitted but I'd be interested in any comments either way.

Share this post


Link to post
Share on other sites

Mike, the common mode choke is in there already, it's the bit with the big 'Z' in it.

Share this post


Link to post
Share on other sites

I was thinking on the lines if the PSU goes to someone else and they don't fit a mains socket with a filter, for whatever reason, then interference goes both ways!

So far the consenus is swap them all out which I must say would be my preferred course of action.

Share this post


Link to post
Share on other sites

Same here I replace them as you can't control what happens to the PSU later.

 

No need to check, just replace as you never know when they will blow.

Share this post


Link to post
Share on other sites

Thanks for all the replies chaps. Replacement is definitely the way to go in that case.:)👍

Share this post


Link to post
Share on other sites

Whilst on the subject of these PSU's does anyone have a rule of thumb for adjusting the voltages? A quick flick through the manual doesn't specify anything unless I missed it. On the 5v rail there's the normal 5v adjustment plus a low voltage drop out adjustment. Should the 5v be set a little higher to overcome cable losses to the main board? 

I haven't tried yet but I would assume one would need to drop the 5v o/p as low as it will go to enable adjustment of the low voltage drop out. I wonder if it will go that low though? Will try it tomorrow and see but otherwise what other way is there?

The 12v adjustment is not so critical so that shouldn't be a problem.

Share this post


Link to post
Share on other sites

5v set to about 5.1v so its 5v at the board

as for the trip pots etc there are no manual settings as they was factory set, so what I do is read the GOOD half of the pot (the side which still has a reading) and set the new pot to that before soldering in, then it is as close to the factory settings as you are going to get, better than just turning them and not knowing where to leave them set!

Share this post


Link to post
Share on other sites

That's true, the only concern is whether the OP amp has changed characteristics with age hence affecting the trip level. It certainly does with the LM723's as I've come across lots of these (old ones) still adjustable but way out of spec.

Share this post


Link to post
Share on other sites
37 minutes ago, midibob said:

That's true, the only concern is whether the OP amp has changed characteristics with age hence affecting the trip level. It certainly does with the LM723's as I've come across lots of these (old ones) still adjustable but way out of spec.

As always then it's down to the repairers knowledge!

Share this post


Link to post
Share on other sites

So say they are removed the rifas that is and you have a mains filter fitted, what's the situation with the machine, is the psu going to fail elsewhere down the line, I have a couple that this has been done and are running grand for now but you recommend they are replaced then?

Share this post


Link to post
Share on other sites

Yep, I haven't had a good chance to look into this with much depth as yet. If the 5v rail can be turned down low enough so that the drop out can be set then it's simples!! Will try tomorrow and report back.

1 minute ago, thompy said:

So say they are removed the rifas that is and you have a mains filter fitted, what's the situation with the machine, is the psu going to fail elsewhere down the line, I have a couple that this has been done and are running grand for now but you recommend they are replaced then?

Personally I think they should all be replaced. I expect the machine probably would run fine but how much interference would be passing back into the mains, or coming in, is up for discussion. More knowledgeable folks on here will probably comment further.

Share this post


Link to post
Share on other sites

Hi all great thread!! :) I've taken out my exploding smoking Rifas, I've fitted a filter to the power supply (as suggested by Nick) but do you guys know where I can get replacement Rifas from and what types. Annoying they are cracked but all look to have the same codes!

Thanks all :)

2020-03-15 18.32.50.jpg

Share this post


Link to post
Share on other sites

All my MPS machines have had the Riffa's removed and a filtered mains input , I have noticed that sometimes (1 in 20 when its left on for any period of time )  when i power off my Reelcrazy it trips the whole house ?

Could this be related ?

Cheers

Stef

Share this post


Link to post
Share on other sites
18 hours ago, RobT said:

Hi all great thread!! :) I've taken out my exploding smoking Rifas, I've fitted a filter to the power supply (as suggested by Nick) but do you guys know where I can get replacement Rifas from and what types. Annoying they are cracked but all look to have the same codes!

Thanks all :)

2020-03-15 18.32.50.jpg

Isn't the value printed on the top of the cap ? I'm in the process of replacing 20 of them and mine all the value printed there . 

 

Capture.JPG

  • Like 1

Share this post


Link to post
Share on other sites
1 hour ago, ssjenkins said:

Isn't the value printed on the top of the cap ? I'm in the process of replacing 20 of them and mine all the value printed there . 

 

Capture.JPG

Cheers for this :) like you I need loads too but want to make sure I order the correct ones, as lots pop up in RS when a search is done 

2020-03-16 14.22.41.jpg

Share this post


Link to post
Share on other sites
17 minutes ago, RobT said:

as lots pop up in RS when a search is done 

 

Indeed Rob . Took me a while to track mine down . 

  • Like 1

Share this post


Link to post
Share on other sites
39 minutes ago, ssjenkins said:

Indeed Rob . Took me a while to track mine down . 

Yeah I have no idea which ones are any good as a replacement, allot are popping up and I just need to find the correct replacements for my old ones (pictured) I need around 7 sets of these but I need to be sure they are the right ones, so it's a little plea on here if anyone knows :)

Share this post


Link to post
Share on other sites

Cheers TTX! :) brilliant will look and order a bunch, thanks again :)

Share this post


Link to post
Share on other sites
On 3/16/2020 at 2:24 PM, RobT said:

Cheers for this :) like you I need loads too but want to make sure I order the correct ones, as lots pop up in RS when a search is done 

2020-03-16 14.22.41.jpg

Hi everyone, appreciate this is a bit of a dead post but I am trying to do the same and find the rifas for my power supply but mine have blown completely and have only fragments left to look at, from what i can put together, they are all the same as these but when I go onto farnell, there are multiple options for each, does anyone know which are right to buy?

Share this post


Link to post
Share on other sites
2 hours ago, Bricey21 said:

Hi everyone, appreciate this is a bit of a dead post but I am trying to do the same and find the rifas for my power supply but mine have blown completely and have only fragments left to look at, from what i can put together, they are all the same as these but when I go onto farnell, there are multiple options for each, does anyone know which are right to buy?

 

  • Haha 1

Share this post


Link to post
Share on other sites

×