Jump to content
oldschoolfruits

maygay m1v screenplay

Recommended Posts

Hye guys.

basically; i bought a knackard old screenplay; crt was shot. Mpu battery damaged. After a few patch repairs the mpu apears to boot up., comes out of reset anyway .all it apears to do is audio alarm in the machine. Ive attached a video. Any info greatfully recieved on this. Also to add.., if theres any mv1 boards out there id be very interested in buying one etc. 

Thanks

Share this post


Link to post
Share on other sites

I did a thread about screenplay repairs and there crt's on another forum, but as I no longer have any access to it I cannot give you the link! the thread should have been deleted many months ago as I requested but it wasn't and I was!!

 

good luck in your quest

  • Like 1

Share this post


Link to post
Share on other sites

Thanks andrew.

board being sent off to a mate who has a working screenplay; so hopefully i can get an idea of where to start. No point me doing the expensive hd upgrade if its a non starter  

Share this post


Link to post
Share on other sites

I personally like the original crt's in these, they give a great display and more vibrant than a lcd

IMG_0907.jpg

IMG_0844.jpg

IMG_0906.jpg

Share this post


Link to post
Share on other sites

Hi there, only just seen this thread, did you get this running? The error in unsquash I believe is an issue with the unpacking of the graphics roms on startup, so likely one of the roms has gone bad or possibly the memory chip but I am no expert on that. It can also be caused if the four graphics roms are not fitted in the correct sequence.

You mentioned the battery was leaking, if it's the same orientation as the one I have seen before unfortunately the battery leak drips directly onto the bottom rom of the plug in game rom card, almost a bullseye on the two corner pins!

Why on earth manufacturers didn't put the battery in the bottom corner away from everything else I have no idea, the benefits we have of years of hindsight I guess!

Edited by Retrofruit

Share this post


Link to post
Share on other sites
2 hours ago, Retrofruit said:

Hi there, only just seen this thread, did you get this running? The error in unsquash I believe is an issue with the unpacking of the graphics roms on startup, so likely one of the roms has gone bad or possibly the memory chip but I am no expert on that. It can also be caused if the four graphics roms are not fitted in the correct sequence.

You mentioned the battery was leaking, if it's the same orientation as the one I have seen before unfortunately the battery leak drips directly onto the bottom rom of the plug in game rom card, almost a bullseye on the two corner pins!

Why on earth manufacturers didn't put the battery in the bottom corner away from everything else I have no idea, the benefits we have of years of hindsight I guess!

Yes the roms were all fine as worked on other boards, the error was down to a bad 68000 cpu, once changed it was fine,

Boards were not meant to last longer than the next tech update, so they did not need to bother about battery replacement as in 5 years time new machines would be the in thing not the old ones! Its like running a word processor program on a BBC B micro today... hands up how many do that rather than using a modern win 10 pc!!  technology marches on!!

Share this post


Link to post
Share on other sites

×