Jump to content
TTX

Castle Big Fifty Repair

Recommended Posts

8 minutes ago, BarcrestPlayers said:

Cool battery mod

That could still leake though onto the board as not fly wired unless it temporary 

Share this post


Link to post
Share on other sites
42 minutes ago, Ben Moore said:

That could still leake though onto the board as not fly wired unless it temporary 

Lithium batteries like these don't tend to leak when they run flat unlike most rechargeable batteries. 

Share this post


Link to post
Share on other sites
23 minutes ago, CanonMan said:

Lithium batteries like these don't tend to leak when they run flat unlike most rechargeable batteries. 

Oh ok then good idea

Share this post


Link to post
Share on other sites

Some more progress, currently waiting for some new turned pin IC sockets to arrive...

2119426705_WaitingforICsockets.thumb.jpg.819d8f45d9270c8a760a4c2f9f0a7ae4.jpg

  • Like 3

Share this post


Link to post
Share on other sites

50 credits worth of gameplay, taken just before stripping all those ICs off the board!

 

  • Like 1

Share this post


Link to post
Share on other sites

Very nice tris .look forward to a jp vid when the board is re populated 

Share this post


Link to post
Share on other sites

The IC sockets arrived today and the MPU is now pretty much done! :)

MPUDone_1.thumb.jpg.7dbfacb78367acee49f4248374224d39.jpg

MPUDone_2.thumb.jpg.3b529766455f18d7858705ccd07ffe3c.jpg

MPUDone_3.thumb.jpg.9d87a3390d429ebcdeb3aaa30b7cfa0a.jpg

MPUDone_4.thumb.jpg.67dd9d24f6b635d5440ef3eddaeb6b11.jpg

Share this post


Link to post
Share on other sites

Looks like a very nice job, those sockets look good 👌

Share this post


Link to post
Share on other sites

Is there anything in particular that you would recommend?

Share this post


Link to post
Share on other sites

It turned out that the power supply was causing RAM corruption on power-down so I replaced all of the electrolytics and the IEC mains filter...

01Before.thumb.jpg.d02c47d4c861d677599849c43de0b555.jpg

 

Old vs new mains filters.

02Filters.thumb.jpg.0122d957ef18d6062b3afbdc448e05fb.jpg

 

An exploded Rifa hiding inside the old filter!!

03BadFilter.thumb.jpg.28fd962c4fae59a781f807500792ad8c.jpg

04BadFilter.thumb.jpg.b9b3b6050f1f2cf6f68fe8b152062a72.jpg

 

Old electrolytics.

05OldCaps.thumb.jpg.589d8a7370784c8548ca0a8361c27a55.jpg

 

New electrolytics. Panasonic and nichicon, no penny pinching here!

06NewCaps.thumb.jpg.f11539fb261302197c44c036bcff21c1.jpg

07NewCaps.thumb.jpg.607c9862cb2f356d9d5013ac5e750ebd.jpg

 

All done!

08Done.thumb.jpg.8ddedd594453c2590d0b378ddd6d9c02.jpg

09Done.thumb.jpg.93f2d9382bc9119ada192f6d055cbf00.jpg

No more RAM corruption! For now, anyway...🤞

Share this post


Link to post
Share on other sites

Top job tris .I had no idea that those filters had rifas inside !.

Share this post


Link to post
Share on other sites

×