Jump to content
Sign in to follow this  
MAGIK

Fixing Crystals MPU4 Fairground sound

Recommended Posts

Posted (edited)

ah I see you edited it.

52 minutes ago, Wizard said:

Post up another screenshot and I'll explain ( or try to lol )

By "changing" a sample, I presume you mean editing its table entry? You can't add any new ones because it will smash the start of the 1st samples data

yep I mean swapping samples 39 and 38 over so the dice whooshes instead of plays lose .

this is what happens atm when I try - 38 becomes the dummy. The two highlighted addresses are swopped over:

 

 

38swapandgone.jpg

Edited by MAGIK

Share this post


Link to post
Share on other sites
Posted (edited)

what happened up there to clarify, was swapping 38 and 39 over , 38 does indeed become 39, but instead of 39 becoming 38, 38 is just the silent sample.

(goes to 256 samples it should be 9180 samples at 1.49 seconds long)

resetting or reloading the game makes no difference, it stays like that until I swap the entrys in the rom back to where they should be.

In theory I think what I am doing is correct, is it going wrong because the address change makes entry 38s address HIGHER than the following one?

Im starting to wonder if I would get more sucess by copying the relevant blocks to a new ROM and then rewriting the lookup table !

 

 

Edited by MAGIK

Share this post


Link to post
Share on other sites

As I said, it's a feature of MFME. I have made some changes to fix it. Check your pm's

Share this post


Link to post
Share on other sites

Good luck with this Magik, hope your able to get them to act correctly.

Share this post


Link to post
Share on other sites

Just about, there is still some fiddling to do. Wont work in MFME properly , but it looks like it runs on real hardware!!

 

  • Like 1

Share this post


Link to post
Share on other sites
Sign in to follow this  

×