Jump to content
Ikhlaq

Italian job need help

Recommended Posts

Hi guys✌

Thought I'd start working on this one whilst waiting for parts, 

When I switched it on lcd came on then initionliesd and it went off with the lamps.

All green lights on power supply 

Pic of machine with part lamps on an lcd not on. 

On the vid shows battery in loom but I used the bigger on ( feel free to bollock me off).

15469747441321686280891.jpg

154697482323632687292.jpg

Share this post


Link to post
Share on other sites

Oh my god,epoch.scrap it,or there are some boards on ebay fot about 80 quid.Epoch is diabolical.

Share this post


Link to post
Share on other sites

No chance of getting it repaired myself?

I'll have a look thanks bro. It's a good machine one of my favourite only reason why I've still got it

Share this post


Link to post
Share on other sites

Managed to get all the lamps on but lcd isn't coming on😭

Share this post


Link to post
Share on other sites

Sure thing buddy I'll post as I get into arcade, met an old friend today he also suggested to break test the 1 amp & lead coming into the alpha display 

Share this post


Link to post
Share on other sites

Probably requires a new mpu and/or a lampboard which the alpha is connected to.

Alpha is one of the first things to suffer from board damage on Epoch.

Share this post


Link to post
Share on other sites

Don’t know which lamp board you have as cannot see it, but if its the one made by one stop ( mk2 version) your most likely need a working one as they are very very prone to the custom chip blowing and alpha not working

Share this post


Link to post
Share on other sites
On 1/10/2019 at 12:52 PM, fruit58 said:

can we see some close up pics of the back of the alpha display 

That's all the boards inside, just done bleep test on 1amp ( it bleeped) & no bleep on the connector on alpha display.

1547223221880211837699.jpg

1547223254184872592139.jpg

15472233150091131488427.jpg

Share this post


Link to post
Share on other sites

look at all the little chips and transister on the boards to see if there is any burn marks or holes on them starting with them on the display

Share this post


Link to post
Share on other sites
3 hours ago, fruit58 said:

look at all the little chips and transister on the boards to see if there is any burn marks or holes on them starting with them on the display

There's no holes or burn marks anywhere 

Share this post


Link to post
Share on other sites

×