Jump to content

Recommended Posts

hi all my name is derek from bridlington have joined your forum for fruit help most probebly like a lot more on here.

my problem looks like the same as everyone else gets maygay power supply got myself a homer simpson meltdown (not working) will try to explain on switching on speaker starts clicking for about 5sceconds green leds light up on all the small boards on the main board just two light up there is also a red flashing light next to the key switch and that is it no other lights on the machine bar the power supply and they are not all lit up but i read someware that even if they are all lit up it does'nt mean to say there is voltage comming out i think i need some sort of readout for what voltages should be across what pins this info would be great if someone can help me thanx "derek"

Share this post


Link to post

there should be a label under the row of LEDs on the power supply . Yes, a missing LED means a voltage has gone down.  Welcome to the forums, hope we can be of help.

 

FYI , the machine is based on EPOCH tech, so when looking for spares search for EPOCH PSU, MPU etc.

 

there are still a few spares about for this tech, they are becoming rarer now tho.

Share this post


Link to post

welcome to the forum , hope you get your machine sorted and stick about .

Share this post


Link to post

24v lamp may be out on the psu you have. This is used for the hopper payout i believe and it is an on demand supply.... Eg, will not light up until the hopper wants to pay out. (I think this was only the case on mk2 psu cards though)

 

As already said, you probably need a new Epoch mpu as they are prone to battery leakage..

 

In most cases the main mpu has 1 blinking led (reset or security, cant remember which one) and the only one unlit should be +Vdisp...

 

Guaranteed working main mpu's aren't cheap these days unfortunately...

 

Was this the machine that was on Ebay a while back, sold in the Brid area for about £37 quid with no keys?

Share this post


Link to post

yeh thats the one mate it came out of the viking pub at flamborough (pub had closed down)

the board with the battery on is in good condition no leakage

just need to find out what pins should have what voltages on there is no label giving the info.

Share this post


Link to post

thanx for the welcome's  guys

just been thinking you can end up buying parts and spending more than the machine is worth.

Share this post


Link to post

With Epoch, they can be very expensive if you need an mpu and other boards to make it work...

 

It is ok if you want the machine for yourself to keep, but don't expect to make a profit on them...

 

If it is the same guy in Brid, i have had quite a bit of stuff from him in the past and my mate was offered this machine prior to Ebay, but was refused as like you say, Epochs get expensive to fix...

Share this post


Link to post

i may have a supply for that,post a pic of front showing connectors.If its anygood to you,£20 inc postage.

Share this post


Link to post

thanx for the welcome's  guys

just been thinking you can end up buying parts and spending more than the machine is worth.

yep,been there done that,especially with epoch.do you want it to work or not

Share this post


Link to post

Hi Derek and welcome hope your new psu sorts out your machine!

Share this post


Link to post

ha got a pick but dont know how to post it ?

Click more reply options next to post ... If on a desktop you should see an add attachment option or something like...

Share this post


Link to post

try a post in the "help" section instead of the new members forum, that may let you add an attatchment.

Share this post


Link to post

power supply has come but have not fitted it yet machine is in garage and cold and damp so think i might warm the boards up with the hair dryer first

also just need to know does the hopper need some money in it before the machine will fire up ?

Share this post


Link to post

dont think it needs coins to fire up,it just wont payout,or if you get a win,some machines just make a light dinging noise as it counts as if it were paying,better to have coins though,so come on derek,does it work or not

Share this post


Link to post

right then another power supply fitted but no joy all lights lit up on power supply and speaker has a steady hiss now no more clicking machine still not lit up' only two leds lit up on main board LD3/LD5 .

upon a more close inspection with magnifying glass there is a thin layer of gunge on the board wher a battery has leaked at sometime.

Share this post


Link to post

Your content will need to be approved by a moderator

Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×